Close

25/02/2013

Qué hacer si pelisalacarta da error y no funciona en XBMC

Si en alguna ocasión te ha salido el horrible mensaje de “!Fallo en el script¡ plugin. video. pelisalacarta” mientras usabas pelisalacarta en XBMC y no has sabido qué hacer, esta entrada te va a gustar :)

He pensado en recopilar los problemas más habituales que pueden aparecerte cuando usas pelisalacarta, y en general cualquiera de los plugins que encontrarás en este blog, para que sepas qué es lo que puedes hacer en cada caso.

Los errores comunes normalmente están controlados, y cuando se producen te encuentras con un educado mensaje informándote del problema que se ha producido. Esto es lo que tendría que pasar siempre.

Sin embargo hay algunos errores que son imprevisibles, y por tanto acabas viendo el molesto mensaje de “Fallo en el script” a la vez que escuchas el “tonito” de XBMC. De vez en cuando las nuevas versiones de los plugins vienen con mejoras tratamiento de estos errores, todos aprendemos con la experiencia.

Y también hay un tipo extraño de errores en XBMC que son imposibles de detectar para tratarlos en consecuencia. Así que tendrás que aprender a identificarlos, porque se producen y no recibes ningún tipo de notificación.

Vamos con la lista.



Nada más abrir pelisalacarta me aparece el mensaje “Fallo en el script”

Cuando este error se produce nada más entrar, es porque algo ha ido rematadamente mal y el plugin no puede hacer las inicializaciones que necesita.

Aquí hay poco que hacer, mi consejo en primer lugar es que pruebes a borrar el plugin y reinstalarlo de nuevo manualmente siguiendo las instrucciones que encontrarás en esta entrada de Mi Media Center. Probablemente el problema venga porque has tocado algo y has alterado los permisos del sistema de ficheros.

Si esto no funciona pide ayuda a otros usuarios más experimentados, pásate por el foro y pon una copia del log de XBMC para que podamos saber el motivo del error. Esta entrada te ayudará a encontrar y descargar el log de XBMC según cuál sea tu plataforma.

Salvo cosas excepcionales no suele ser necesario reformatear el equipo, reinstalar XBMC ni volver a hacer el jailbreak al ATV2 :)

Al entrar en un canal me aparece el mensaje de “Fallo en el script” o uno que dice “El canal no funciona correctamente”

Has conseguido entrar al plugin y algunos canales te funcionan, pero cuando entras en otros te aparece nuevamente el mensaje de error.

En realidad este caso no tiene nada de excepcional, los “canales” de mis plugins son programas especializados en leer e interpretar sitios web. Cada vez que un sitio web cambia, algo bastante habitual, el programa deja de funcionar y es necesario corregirlo.

Lo único que puedes hacer aquí es probar con otro canal, la razón por la que hay tantos es precisamente tener siempre alternativas disponibles. Los que se van rompiendo los voy arreglando periódicamente.

Al entrar en un canal sale el menú de opciones, pero luego no aparecen las pelis o los sitios donde verlas

Este caso es el mismo que el anterior. El esquema que utiliza el canal para encontrar las pelis ya no es válido porque el sitio web ha realizado cambios, así que la búsqueda no devuelve nada.

Como en el caso anterior, la solución es buscar otro canal.

Al ver elegir el vídeo en un servidor me sale el mensaje “Se ha producido un error en el conector”, o “No se puede encontrar el vídeo”

De la misma forma que los canales son programas hechos para interpretar los sitios web de pelis, los conectores se encargan de obtener el enlace al vídeo en el servidor donde está alojado (putlocker, nowvideo, etc.). Cuando el servidor cambia el esquema de obtención del vídeo el conector deja de funcionar, y hay que actualizarlo.

En este caso lo único que puedes hacer es probar a ver el mismo vídeo en otro servidor (siempre suele haber alternativas), y esperar a que se solucione en futuras versiones si es posible.

Al elegir el vídeo me sale el mensaje “No hay nada para reproducir”

Este mensaje sale cuando pelisalacarta busca vídeos para ver y no encuentra ninguno. Los enlaces a los vídeos se obtienen buscando un montón de posibles patrones en la página donde están los vídeos, y si esta búsqueda no devuelve resultados es cuando pelisalacarta muestra ese mensaje.

Si encuentras este caso repórtalo para que pueda revisarlo cuanto antes. Ya que normalmente se debe a servidores que aún no son compatibles con pelisalacarta (siempre ando buscando de estos) o a formatos de URL que no están en la lista de los servidores compatibles (también es importante catalogarlos).

Al elegir el vídeo en un servidor me sale el mensaje “El vídeo ha sido borrado”

Es lo que tiene ver pelis en servidores piratones, a veces alguien se da cuenta de que se trata de una peli pirata y ordena su borrado.

Si te pasa esto busca otro enlace distinto para ver la peli, no hay nada que hacer.

Le doy a reproducir, sale la espiral de carga y luego no hace nada.

Hay dos motivos por los que te puede pasar esto, lamentablemente es un fallo que no puede detectarse desde pelisalacarta ya que se origina en el reproductor de XBMC.

El primer motivo y el más habitual es que los servidores donde se alojan los vídeos suelen ir algo lentos, así que tienes que aumentar el tiempo de espera de XBMC. Para hacerlo lee esta entrada donde se explica cómo optimizar en XBMC tanto el tiempo de espera como el buffer. Es imprescindible hacer esto en tu XBMC para ver cosas sin problemas si tienes Eden (versión 11) o superior.

Otro motivo puede venir por un sistema de protección del servidor de vídeos, algo que ocurre por ejemplo en rapidvideo en el momento de escribir estas líneas. El servidor detecta que no estás viendo el vídeo desde la página original y por tanto lo bloquea, haciendo que el reproductor de XBMC falle. Este problema no se puede detectar fácilmente, estoy trabajando en ello para que sea más sencillo de evitar.

Si te pasa lo mismo con varios vídeos seguidos XBMC acaba mostrando un mensaje de error muy críptico, algo así como “Demasiados intentos de lista de reproducción abortados” o algo por el estilo. Nunca he entendido muy bien por qué no dice simplemente “No se puede reproducir el vídeo”.

Al elegir el vídeo en un servidor me sale el mensaje “Necesitas una cuenta premium en XXX para ver este vídeo”

Algunos vídeos no se pueden ver sin cuenta premium, a veces por las protecciones que incluyen, a veces porque su visionado sin cuenta es imposible o simplemente porque no están soportados en pelisalacarta de otra manera todavía.

En este caso lo que puedes hacer es buscar una alternativa gratuita para ver el mismo vídeo, tienes un montón recogidas en esta entrada del blog, o bien comprar una cuenta premium para ver vídeos en ese servidor. El mensaje que aparece al ver el vídeo te indica qué tipos de cuenta son compatibles con el servidor que has elegido.

Tengo prevista una entrada para publicar en el blog explicando las diferencias entre los cuatro servidores premium soportados en pelisalacarta (Filenium, Real Debrid, All Debrid y Uploaded), para aclarar las dudas que puedan quedar en este sentido y dar mi opinión sobre cada una.

109 Comments on “Qué hacer si pelisalacarta da error y no funciona en XBMC

Acris
09/05/2016 at 0:08

Llevo un par de semanas que al querer ver un capítulo de csi new york en series blanco me sale el mensaje de ” no hay nada que reproducir”. Lo podéis solucionar? Un saludo y gracias.

Responder
Nefer
10/06/2016 at 15:49

Hola
A mí me pasa lo q ha muchos. El buscador se queda pillado cuando llega a doramastv y no hay forma.

Responder
José manuel
11/06/2016 at 18:59

A mi me pasa que el buscador se queda ‘pillado’ en doramastv. He formateado teniendo un recalbox de inicio, a un openelec y nada, no hay manera sigue haciéndolo.
Hay alguna manera d solucionarlo?
Gracias de antebrazo

Responder
Miguel
10/07/2016 at 14:10

Hola, a mi lo que me pasa es que no me deja añadir películas a la biblioteca desde la versión 4.0.9, incluso con la última (4.1.1).A alguien más le pasa? Alguna solución?

Responder
Jesus
10/07/2016 at 14:12

Le echaremos un vistazo…

Responder
José A. Valera
19/07/2016 at 14:15

Desde ayer,18-07-2015, me sale el mensaje “No hay nada para reproducir”, en especial en HdFull. Empezó por las noche, por la tarde estuve viendo una serie sin ningún problema.

Responder
José A. Valera
19/07/2016 at 17:56

Me sale el mensaje “No hay nada para reproducir” desde ayer, 18-07-2016, por la noche. En HdFull es global.

Responder
Carlos
20/07/2016 at 19:36

Confirmo, en HDFULL sale en todo el mensaje “no hay nada para reproducir”

Responder
Daniel
23/07/2016 at 1:47

No me carga las series de la aplicacion de seriesflv no me aparecen desde jaace unas horas esta mañana si iba bien

Responder
José A. Valera
24/07/2016 at 10:30

Lo de seriesflv lo detecté ayer por la tarde, 23-07-16. El dia anterior,22-07-16, estuve viendo algunos capítulos sin problemas.

Responder
Mari
27/07/2016 at 16:18

Alguien como solucionarlo?

Responder
José A. Valera
29/07/2016 at 14:32

HdFull lo estoy usando entrando directamente a hdfull.tv ohdful.tv/series.

Responder
willy
31/07/2016 at 14:58

ami me pasa que cuando pongo una peli para añadir a la lista de descarga luego voy a descargarrla y me sale error un mensaje comprueba el log para ver mas detalles del error

Responder
José A. Valera
05/08/2016 at 11:34

Ayer, 4-9-16, istalé el nuevo puglin: HdFull funcionó perfectamente. Gracias.

Responder
Pepe Escribano
22/08/2016 at 12:39

Hola Jesus, ante todo agradecer el gran trabajo que realizas con este addon tan fabuloso. Me gustaría preguntarte alguna cosa que veo que es importante y que le pasa a mucha gente por lo que veo. Según la configuración que apliques al addon en reproducción de video (setresolver, bult-in, direct, mandar al jdownloader) hace que o salga el mensaje de lista de reproduccion abortada o que directamente no salga el contenido, y si como es en mi caso que añado los strm para compartir los enlaces con más gente da un error directamente con la ultima versión. Habría alguna posibilidad de o quitar que no salga el error de lista abortada (lo digo porque en segundo plano la película sigue reproducéndose , pero al darle al ok se para por completo) o hacer una opción que lo establezca de forma automática el modo de reproducción? Creo que con esto, tu addon sería la repera ya!! GRACIASSSS!!

Responder
María Asunción
29/09/2016 at 16:09

Hola. Soy absolutamente nueva en esto de kodi y estoy aprendiendo poco a poco. He instalado pelisalacarta desde el repositorio de kodi. ¿es igual hacerlo asi o hay que hacerlo descargando el zip desde pelisalacarta?. Por otro lado, tengo muchos problemas. Muchas veces me sale el mensaje de que se necesita libtorrent, y no se como hay que hacer para ponerlo. Otra gran duda que tengo con pelisalacarta es ¿como hago para ver las peliculas 3D? no se me carga ninguna, y yo tengo la sospecha de que me faltan addons para completar pelisalacarta y poder verlo todo bien. ¿que me dices respecto a esto?. Muchas veces cuando me salen errores y no puedo ver las cosas, posiblemente será que han desaparecido los canales,pero yo enseguida pienso que como soy nueva en esto, algo he hecho mal y por eso no veo las cosas. Por ejemplo, es imposible ver nada en TV-VIP. Siempre me sale el siguiente mensaje: Error inesperado en el canal tvvip. Esto suele pasar cuando hay un fallo de conexión, cuando la web del canal ha cambiado su estructura o simplemente porque hay algo mal en pelisalacarta. Para saber mas detalles consulta el log. ¿Que tengo que hacer para poder ver TV-VIP?

Responder
Luis
07/10/2016 at 1:46

Hola amigo mi nombre es luis soy de Lima Peru he adquirido un android tv bos el h96 Pro octacore 6.0 android, se supone de que este dispositivo es de ultima gama. Tiene kodi kripton pero este no puedo instalar torrenter y ver archivos torrents en pelisalacarta utilizando newpct1 sale uno o sale error porfavor alguna manera como instalar este estupendo addon y ultimamente quasar cuando recien lo.instale estaba bien pero ahora sale error …

Responder
Joaquin
07/11/2016 at 0:14

Jesus; desde hace dos dias no funciona la aplicacion zpeliculas no se si la han cerrado te ruego si me lo puedes aclaral Gracias por anticipada

Responder
Joaquin
07/11/2016 at 0:22

No me funciona la aplicacion zpeliculas espero respuesta Gracias jesus

Responder
José A. Valera
30/11/2016 at 10:20

Ayer noche dejo de funcionar HdFull, los problemas empezaron anteayer noche. Lo comunico por si tiene solución. La página web sí que va.

Un saludo

Responder
Jose Teofilo
01/12/2016 at 16:13

Hola Jesus te informo que en todas las plataforma que tengo intalado plelia la carta me esta dando error en loa conectores no puedo ver series tituladas que puedo hacer . La versinon de kodi es 16.1 tanto en android como en window

Responder

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *